
<!DOCTYPE html>

<!--[if IE 8]> <html class="ie ie8" lang="en-US"> <![endif]-->
<!--[if IE 9]> <html class="ie ie9" lang="en-US"> <![endif]-->
<!--[if gt IE 9]><!--> <html lang="en-US"> <!--<![endif]-->

<head>


<meta charset="UTF-8" />
<title>  DJ Spotlight of the Week | Lorenza Centi</title>

 
<meta name="viewport" content="width=device-width, initial-scale=1" />
<link rel="pingback" href="http://impact89fm.org/xmlrpc.php" />
	

	
          <script>
            (function(d){
              var js, id = 'powr-js', ref = d.getElementsByTagName('script')[0];
              if (d.getElementById(id)) {return;}
              js = d.createElement('script'); js.id = id; js.async = true;
              js.src = '//www.powr.io/powr.js';
              js.setAttribute('powr-token','xIFozOQdUX1455032721');
              js.setAttribute('external-type','wordpress');
              ref.parentNode.insertBefore(js, ref);
            }(document));
          </script>
          <!-- JM Twitter Cards by Julien Maury 7.8 -->
<meta name="twitter:card" content="summary">
<meta name="twitter:creator" content="@WDBM">
<meta name="twitter:site" content="@WDBM">
<meta name="twitter:title" content="DJ Spotlight of the Week | Lorenza Centi">
<meta name="twitter:description" content="Our new DJ Spotlight of the Week is Lorenza Centi! Not only is she a DJ here at Impact, but she is also our Head Graphic Designer! When she&#039;s not studying, you guessed it, graphic design, she&#039;s in the">
<meta name="twitter:image" content="http://impact89fm.org/wp-content/uploads/2017/04/DJ-Spotlight_lorenza.jpg">
<!-- /JM Twitter Cards by Julien Maury 7.8 -->
<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//p.jwpcdn.com' />
<link rel='dns-prefetch' href='//w.sharethis.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Impact 89FM | WDBM &raquo; Feed" href="http://impact89fm.org/feed/" />
<link rel="alternate" type="application/rss+xml" title="Impact 89FM | WDBM &raquo; Comments Feed" href="http://impact89fm.org/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Impact 89FM | WDBM &raquo; DJ Spotlight of the Week | Lorenza Centi Comments Feed" href="http://impact89fm.org/blog/dj-spotlight-of-the-week-lorenza-centi/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/impact89fm.org\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.4"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='dashicons-css'  href='http://impact89fm.org/wp-includes/css/dashicons.min.css?ver=4.7.4' type='text/css' media='all' />
<link rel='stylesheet' id='thickbox-css'  href='http://impact89fm.org/wp-includes/js/thickbox/thickbox.css?ver=4.7.4' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='http://impact89fm.org/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=4.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='rs-plugin-settings-css'  href='http://impact89fm.org/wp-content/plugins/revslider/rs-plugin/css/settings.css?rev=4.6.0&#038;ver=4.7.4' type='text/css' media='all' />
<style id='rs-plugin-settings-inline-css' type='text/css'>
.tp-caption a{color:#ff7302;text-shadow:none;-webkit-transition:all 0.2s ease-out;-moz-transition:all 0.2s ease-out;-o-transition:all 0.2s ease-out;-ms-transition:all 0.2s ease-out}.tp-caption a:hover{color:#ffa902}.tp-caption a{color:#ff7302;text-shadow:none;-webkit-transition:all 0.2s ease-out;-moz-transition:all 0.2s ease-out;-o-transition:all 0.2s ease-out;-ms-transition:all 0.2s ease-out}.tp-caption a:hover{color:#ffa902}.tp-caption a{color:#ff7302;text-shadow:none;-webkit-transition:all 0.2s ease-out;-moz-transition:all 0.2s ease-out;-o-transition:all 0.2s ease-out;-ms-transition:all 0.2s ease-out}.tp-caption a:hover{color:#ffa902}.tp-caption a{color:#ff7302;text-shadow:none;-webkit-transition:all 0.2s ease-out;-moz-transition:all 0.2s ease-out;-o-transition:all 0.2s ease-out;-ms-transition:all 0.2s ease-out}.tp-caption a:hover{color:#ffa902}
</style>
<link rel='stylesheet' id='ssbaFont-css'  href='//fonts.googleapis.com/css?family=Indie+Flower&#038;ver=4.7.4' type='text/css' media='all' />
<link rel='stylesheet' id='smartmag-fonts-css'  href='http://fonts.googleapis.com/css?family=Open+Sans:400,600,700|Roboto+Slab' type='text/css' media='all' />
<link rel='stylesheet' id='smartmag-core-css'  href='http://impact89fm.org/wp-content/themes/smart-mag/style.css?ver=2.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='smartmag-responsive-css'  href='http://impact89fm.org/wp-content/themes/smart-mag/css/responsive.css?ver=2.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='pretty-photo-css'  href='http://impact89fm.org/wp-content/themes/smart-mag/css/prettyPhoto.css?ver=2.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='smartmag-font-awesome-css'  href='http://impact89fm.org/wp-content/themes/smart-mag/css/fontawesome/css/font-awesome.min.css?ver=2.4.1' type='text/css' media='all' />
<style id='smartmag-font-awesome-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='wpgform-css-css'  href='http://impact89fm.org/wp-content/plugins/wpgform/css/wpgform.css?ver=4.7.4' type='text/css' media='all' />
<script type='text/javascript' src='http://impact89fm.org/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://impact89fm.org/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPSpinAjax = {"url":"http:\/\/impact89fm.org\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://cdnjs.cloudflare.com/ajax/libs/underscore.js/1.4.2/underscore-min.js?ver=4.7.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPSpinAjax = {"url":"http:\/\/impact89fm.org\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://cdnjs.cloudflare.com/ajax/libs/backbone.js/0.9.2/backbone-min.js?ver=4.7.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPSpinAjax = {"url":"http:\/\/impact89fm.org\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://impact89fm.org/wp-content/plugins/WPSpin/assets/js/backbone-mediator.js?ver=4.7.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPSpinAjax = {"url":"http:\/\/impact89fm.org\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://impact89fm.org/wp-content/plugins/WPSpin/assets/js/playlist/collection.js?ver=4.7.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPSpinAjax = {"url":"http:\/\/impact89fm.org\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://impact89fm.org/wp-content/plugins/WPSpin/assets/js/playlist/model.js?ver=4.7.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPSpinAjax = {"url":"http:\/\/impact89fm.org\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://impact89fm.org/wp-content/plugins/WPSpin/assets/js/playlist/view.js?ver=4.7.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPSpinAjax = {"url":"http:\/\/impact89fm.org\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://impact89fm.org/wp-content/plugins/WPSpin/assets/js/playlist/song_model.js?ver=4.7.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPSpinAjax = {"url":"http:\/\/impact89fm.org\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://impact89fm.org/wp-content/plugins/WPSpin/assets/js/playlist/playlist_collection.js?ver=4.7.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPSpinAjax = {"url":"http:\/\/impact89fm.org\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://impact89fm.org/wp-content/plugins/WPSpin/assets/js/playlist/listen_view.js?ver=4.7.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPSpinAjax = {"url":"http:\/\/impact89fm.org\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://impact89fm.org/wp-content/plugins/WPSpin/assets/js/nowplaying/collection.js?ver=4.7.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPSpinAjax = {"url":"http:\/\/impact89fm.org\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://impact89fm.org/wp-content/plugins/WPSpin/assets/js/nowplaying/model.js?ver=4.7.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPSpinAjax = {"url":"http:\/\/impact89fm.org\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://impact89fm.org/wp-content/plugins/WPSpin/assets/js/nowplaying/view.js?ver=4.7.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPSpinAjax = {"url":"http:\/\/impact89fm.org\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://impact89fm.org/wp-content/plugins/WPSpin/assets/js/nowplaying/nowplaying_model.js?ver=4.7.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPSpinAjax = {"url":"http:\/\/impact89fm.org\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://impact89fm.org/wp-content/plugins/WPSpin/assets/js/nowplaying/nowplaying_view.js?ver=4.7.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPSpinAjax = {"url":"http:\/\/impact89fm.org\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://impact89fm.org/wp-content/plugins/WPSpin/assets/js/nowplaying/nowplaying_collection.js?ver=4.7.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPSpinAjax = {"url":"http:\/\/impact89fm.org\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://impact89fm.org/wp-content/plugins/WPSpin/assets/js/main.js?ver=4.7.4'></script>
<script type='text/javascript' src='http://p.jwpcdn.com/6/12/jwplayer.js?ver=4.7.4'></script>
<script type='text/javascript' src='http://impact89fm.org/wp-content/plugins/revslider/rs-plugin/js/jquery.themepunch.tools.min.js?rev=4.6.0&#038;ver=4.7.4'></script>
<script type='text/javascript' src='http://impact89fm.org/wp-content/plugins/revslider/rs-plugin/js/jquery.themepunch.revolution.min.js?rev=4.6.0&#038;ver=4.7.4'></script>
<script id='st_insights_js' type='text/javascript' src='http://w.sharethis.com/button/st_insights.js?publisher=4d48b7c5-0ae3-43d4-bfbe-3ff8c17a8ae6&#038;product=simpleshare'></script>
<script type='text/javascript' src='http://impact89fm.org/wp-content/plugins/wp-retina-2x/js/picturefill.min.js?ver=3.0.2'></script>
<script type='text/javascript' src='http://impact89fm.org/wp-content/themes/smart-mag/js/jquery.prettyPhoto.js?ver=4.7.4'></script>
<script type='text/javascript' src='http://impact89fm.org/wp-content/plugins/simple-popup-plugin/scripts/jquery.cookie.js?ver=4.7.4'></script>
<link rel='https://api.w.org/' href='http://impact89fm.org/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://impact89fm.org/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://impact89fm.org/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='City Pulse on the Air | 4.22.17' href='http://impact89fm.org/blog/city-pulse-on-the-air-4-22-17/' />
<meta name="generator" content="WordPress 4.7.4" />
<link rel="canonical" href="http://impact89fm.org/blog/dj-spotlight-of-the-week-lorenza-centi/" />
<link rel='shortlink' href='http://impact89fm.org/?p=45112' />
<link rel="alternate" type="application/json+oembed" href="http://impact89fm.org/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fimpact89fm.org%2Fblog%2Fdj-spotlight-of-the-week-lorenza-centi%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://impact89fm.org/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fimpact89fm.org%2Fblog%2Fdj-spotlight-of-the-week-lorenza-centi%2F&#038;format=xml" />
<script type="text/javascript"><!--
function powerpress_pinw(pinw_url){window.open(pinw_url, 'PowerPressPlayer','toolbar=0,status=0,resizable=1,width=460,height=320');	return false;}
//-->
</script>

<!-- Bad Behavior 2.2.19 run time: 5.535 ms -->
<script type="text/javascript">
<!--
function bb2_addLoadEvent(func) {
	var oldonload = window.onload;
	if (typeof window.onload != 'function') {
		window.onload = func;
	} else {
		window.onload = function() {
			oldonload();
			func();
		}
	}
}

bb2_addLoadEvent(function() {
	for ( i=0; i < document.forms.length; i++ ) {
		if (document.forms[i].method == 'post') {
			var myElement = document.createElement('input');
			myElement.setAttribute('type', 'hidden');
			myElement.name = 'bb2_screener_';
			myElement.value = '1493123880 162.144.124.190 54.224.77.253, 162.144.124.190';
			document.forms[i].appendChild(myElement);
		}
	}
});
// --></script>
		
			<!--/ Facebook Thumb Fixer Open Graph /-->
			<meta property="og:type" content="article" />
			<meta property="og:url" content="http://impact89fm.org/blog/dj-spotlight-of-the-week-lorenza-centi/" />
			<meta property="og:title" content="DJ Spotlight of the Week | Lorenza Centi" />
			<meta property="og:description" content="" />
			<meta property="og:site_name" content="Impact 89FM | WDBM" />
			<meta property="og:image" content="http://impact89fm.org/wp-content/uploads/2017/04/DJ-Spotlight_lorenza.jpg" />

			<meta itemscope itemtype="article" />
			<meta itemprop="description" content="" />
			<meta itemprop="image" content="http://impact89fm.org/wp-content/uploads/2017/04/DJ-Spotlight_lorenza.jpg" />
			

<script type="text/javascript">jwplayer.defaults = { "ph": 2 };</script>	<!--Simple Popup Plugin v4.0 / RH Mods-->
	<script language="javascript" type="text/javascript">
	<!--
	var swin=null;
	function popitup(mypage,w,h,pos,myname,infocus){
	    if (w!=parseInt(w)||w<=0) w=$width;
	    if (h!=parseInt(h)||h<=0) h=$height;
	    if (myname==null){myname="swin"};
	    var myleft = 30;
	    var mytop = 30;
	    if (myleft==0 && mytop==0 && pos!="random"){pos="center"};
	    if (pos=="random"){myleft=(screen.width)?Math.floor(Math.random()*(screen.width-w)):100;mytop=(screen.height)?Math.floor(Math.random()*((screen.height-h)-75)):100;}
	    if (pos=="center"){myleft=(screen.width)?(screen.width-w)/2:100;mytop=(screen.height)?(screen.height-h)/2:100;}
	    settings="width=" + w + ",height=" + h + ",top=" + mytop + ",left=" + myleft + ",scrollbars=no,location=no,directories=no,status=no,menubar=no,toolbar=no,resizable=no";swin=window.open(mypage,myname,settings);
	    if (infocus==null || infocus=="front"){swin.focus()};
	    return false;
	}
	// -->
	</script>
	<!--/Simple Popup Plugin-->
	<script>(function(d, s, id){
                 var js, fjs = d.getElementsByTagName(s)[0];
                 if (d.getElementById(id)) {return;}
                 js = d.createElement(s); js.id = id;
                 js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.6";
                 fjs.parentNode.insertBefore(js, fjs);
               }(document, 'script', 'facebook-jssdk'));</script><style type="text/css">	.ssba {
									
									
									
									-moz-border-radius: 10px; -webkit-border-radius: 10px; -khtml-border-radius: 10px;  border-radius: 10px; -o-border-radius: 10px;
								}
								.ssba img
								{
									width: 32px !important;
									padding: 6px;
									border:  0;
									box-shadow: none !important;
									display: inline !important;
									vertical-align: middle;
								}
								.ssba, .ssba a
								{
									text-decoration:none;
									border:0;
									background: none;
									font-family: Indie Flower;
									font-size: 	20px;
									
									
								}
								.ssba_sharecount:after, .ssba_sharecount:before {
									right: 100%;
									border: solid transparent;
									content: " ";
									height: 0;
									width: 0;
									position: absolute;
									pointer-events: none;
								}
								.ssba_sharecount:after {
									border-color: rgba(224, 221, 221, 0);
									border-right-color: #f5f5f5;
									border-width: 5px;
									top: 50%;
									margin-top: -5px;
								}
								.ssba_sharecount:before {
									border-color: rgba(85, 94, 88, 0);
									border-right-color: #e0dddd;
									border-width: 6px;
									top: 50%;
									margin-top: -6px;
								}
								.ssba_sharecount {
									font: 11px Arial, Helvetica, sans-serif;

									padding: 5px;
									-khtml-border-radius: 6px;
									-o-border-radius: 6px;
									-webkit-border-radius: 6px;
									-moz-border-radius: 6px;
									border-radius: 6px;
									position: relative;
									border: 1px solid #e0dddd;color: #555e58;
										background: #f5f5f5;
									}
									.ssba_sharecount:after {
										border-right-color: #f5f5f5;
									}</style><link rel="shortcut icon" href="/wp-content/uploads/fbrfg/favicon.ico">
<link rel="apple-touch-icon" sizes="57x57" href="/wp-content/uploads/fbrfg/apple-touch-icon-57x57.png">
<link rel="apple-touch-icon" sizes="114x114" href="/wp-content/uploads/fbrfg/apple-touch-icon-114x114.png">
<link rel="apple-touch-icon" sizes="72x72" href="/wp-content/uploads/fbrfg/apple-touch-icon-72x72.png">
<link rel="apple-touch-icon" sizes="144x144" href="/wp-content/uploads/fbrfg/apple-touch-icon-144x144.png">
<link rel="apple-touch-icon" sizes="60x60" href="/wp-content/uploads/fbrfg/apple-touch-icon-60x60.png">
<link rel="apple-touch-icon" sizes="120x120" href="/wp-content/uploads/fbrfg/apple-touch-icon-120x120.png">
<link rel="apple-touch-icon" sizes="76x76" href="/wp-content/uploads/fbrfg/apple-touch-icon-76x76.png">
<link rel="apple-touch-icon" sizes="152x152" href="/wp-content/uploads/fbrfg/apple-touch-icon-152x152.png">
<link rel="apple-touch-icon" sizes="180x180" href="/wp-content/uploads/fbrfg/apple-touch-icon-180x180.png">
<meta name="apple-mobile-web-app-title" content="Impact 89FM">
<link rel="icon" type="image/png" href="/wp-content/uploads/fbrfg/favicon-192x192.png" sizes="192x192">
<link rel="icon" type="image/png" href="/wp-content/uploads/fbrfg/favicon-160x160.png" sizes="160x160">
<link rel="icon" type="image/png" href="/wp-content/uploads/fbrfg/favicon-96x96.png" sizes="96x96">
<link rel="icon" type="image/png" href="/wp-content/uploads/fbrfg/favicon-16x16.png" sizes="16x16">
<link rel="icon" type="image/png" href="/wp-content/uploads/fbrfg/favicon-32x32.png" sizes="32x32">
<meta name="msapplication-TileColor" content="#ffffff">
<meta name="msapplication-TileImage" content="/wp-content/uploads/fbrfg/mstile-144x144.png">
<meta name="msapplication-config" content="/wp-content/uploads/fbrfg/browserconfig.xml">
<meta name="application-name" content="Impact 89FM">
<!-- BEGIN GADWP v4.9.6.2 Universal Tracking - https://deconf.com/google-analytics-dashboard-wordpress/ -->
<script type="text/javascript">
(function($){
    $(window).load(function() {
        
            //Track Downloads
            $('a').filter(function() {
                return this.href.match(/.*\.(zip|mp3*|mpe*g|pdf|docx*|pptx*|xlsx*|jpe*g|png|gif|tiff|rar*)(\?.*)?$/);
            }).click(function(e) {
                ga('send','event', 'download', 'click', this.href);
            });

            //Track Mailto
            $('a[href^="mailto"]').click(function(e) {
                ga('send','event', 'email', 'send', this.href);
             });
            
            //Track Outbound Links
            $('a[href^="http"]').filter(function() {
                if (!this.href.match(/.*\.(zip|mp3*|mpe*g|pdf|docx*|pptx*|xlsx*|jpe*g|png|gif|tiff|rar*)(\?.*)?$/)){
                    if (this.href.indexOf('impact89fm.org') == -1) return this.href;
                }
            }).click(function(e) {
                ga('send','event', 'outbound', 'click', this.href);
            });
		    		                });
})(jQuery);
</script>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-2052519-1', 'auto');
  ga('require', 'displayfeatures');
  ga('send', 'pageview');
</script>

<!-- END GADWP Universal Tracking -->

	
<!--[if lt IE 9]>
<script src="http://impact89fm.org/wp-content/themes/smart-mag/js/html5.js" type="text/javascript"></script>
<![endif]-->

</head>

<body class="post-template-default single single-post postid-45112 single-format-standard page-builder right-sidebar full">

<div class="main-wrap">

	
	
	<div class="top-bar">

		<div class="wrap">
			<section class="top-bar-content">
			
				
				
				<div class="search">
					<form role="search" action="http://impact89fm.org/" method="get">
						<input type="text" name="s" class="query" value="" placeholder="Search..." />
						<button class="search-button" type="submit"><i class="fa fa-search"></i></button>
					</form>
				</div> <!-- .search -->
							<div class="textwidget"><ul class="social-icons">
	<li><a href="https://www.facebook.com/impact89fm" class="icon fa fa-facebook" title="Facebook"><span class="visuallyhidden">Facebook</span></a></li>
	<li><a href="http://twitter.com/WDBM" class="icon fa fa-twitter" title="Twitter"><span class="visuallyhidden">Twitter</span></a></li>
<li><a href="https://instagram.com/impact89fm/" class="icon fa fa-instagram" title="Instagram"><span class="visuallyhidden">Instagram</span></a></li>
<li><a href="https://www.linkedin.com/company/impact-89fm" class="icon fa fa-linkedin" title="LinkedIn"><span class="visuallyhidden">LinkedIn</span></a></li>
<li><a href="http://impact89fm.tumblr.com/" class="icon fa fa-tumblr" title="Tumblr"><span class="visuallyhidden">Tumblr</span></a></li>
<li><a href="https://plus.google.com/u/0/101717256499051554438/about" class="icon fa fa-google-plus" title="Google+"><span class="visuallyhidden">Google+</span></a></li>
<li><a href="https://www.youtube.com/user/impact89fm" class="icon fa fa-youtube" title="YouTube"><span class="visuallyhidden">YouTube</span></a></li>
<li><a href="http://impact89fm.org/app/" class="icon fa fa-download" title="App"><span class="visuallyhidden">App</span></a></li>
</ul></div>
						
			</section>
		</div>
		
	</div>
	
	
	<div id="main-head" class="main-head">
		
		<div class="wrap">
		
			<header>
				<div class="title">
				
				<a href="http://impact89fm.org/" title="Impact 89FM | WDBM" rel="home">
									
					<img src="http://impact89fm.org/wp-content/uploads/2013/09/impact_360.png" class="logo-image" alt="Impact 89FM | WDBM" data-at2x="http://impact89fm.org/wp-content/uploads/2015/04/Main-Banner2a.png" />
						 
								</a>
				
				</div>
				
				<div class="right">
					<a href="http://impact89fm.org/listenlive/" id="" target="_self" class="widget_sp_image-image-link" title="" rel=""><img width="300" height="136" alt="" class="attachment-medium" style="max-width: 100%;" srcset="http://impact89fm.org/wp-content/uploads/2013/09/listen_live_720-300x136.png, http://impact89fm.org/wp-content/uploads/2013/09/listen_live_720-300x136@2x.png 2x" /></a>				</div>
		<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-2052519-2', 'auto');
  ga('send', 'pageview');

</script>	</header>
			
						
			<nav class="navigation cf" data-sticky-nav="1" data-sticky-logo="1">
			
				<div class="mobile" data-type="classic" data-search="1">
					<a href="#" class="selected">
						<span class="text">Navigate</span><span class="current"></span> <i class="hamburger fa fa-bars"></i>
					</a>
				</div>
				
				<div class="menu-main-menu-container"><ul id="menu-main-menu" class="menu"><li class="sticky-logo"><a href="http://impact89fm.org/"><img src="http://impact89fm.org/wp-content/uploads/2015/03/MainLogo-125x125-e1427157706791.png" /></a></li><li id="menu-item-4798" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4798"><a href="http://www.impact89fm.org">Home</a></li>
<li id="menu-item-21708" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-cat-349 menu-item-21708"><a href="http://impact89fm.org/blog/category/music/">Read</a>
<ul class="sub-menu">
	<li id="menu-item-39038" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-39038"><a href="http://impact89fm.org/music">Music</a>
	<ul class="sub-menu">
		<li id="menu-item-40270" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-7590 menu-item-40270"><a href="http://impact89fm.org/blog/category/music/the-low-down-music/">The Low Down</a></li>
		<li id="menu-item-40265" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-7705 menu-item-40265"><a href="http://impact89fm.org/blog/category/music/artist-profile-2/">Artist Profile</a></li>
		<li id="menu-item-40276" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-20 menu-item-40276"><a href="http://impact89fm.org/blog/category/music/interviews/">Interviews</a></li>
		<li id="menu-item-40266" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-7711 menu-item-40266"><a href="http://impact89fm.org/blog/category/music/icymi/">ICYMI</a></li>
		<li id="menu-item-40272" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-7712 menu-item-40272"><a href="http://impact89fm.org/blog/category/music/watch-for-the-music/">Watch for the Music</a></li>
		<li id="menu-item-40271" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-7713 menu-item-40271"><a href="http://impact89fm.org/blog/category/music/starter-pack/">Starter Pack</a></li>
		<li id="menu-item-21949" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-408 menu-item-21949"><a href="http://impact89fm.org/blog/category/jam-of-the-day/">Jam of the Day</a></li>
		<li id="menu-item-40269" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-7714 menu-item-40269"><a href="http://impact89fm.org/blog/category/music/overunder/">Over/Under</a></li>
		<li id="menu-item-40267" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-4795 menu-item-40267"><a href="http://impact89fm.org/blog/category/music/reviews/album-reviews/">Album Reviews</a></li>
		<li id="menu-item-40268" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-4796 menu-item-40268"><a href="http://impact89fm.org/blog/category/music/reviews/concert-reviews/">Concert Reviews</a></li>
	</ul>
</li>
	<li id="menu-item-13208" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-13208"><a title="Impact Sports" href="http://impact89fm.org/sports/">Sports</a>
	<ul class="sub-menu">
		<li id="menu-item-39161" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39161"><a href="http://impact89fm.org/sports">Impact Sports Home Page</a></li>
		<li id="menu-item-40278" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-7595 menu-item-40278"><a href="http://impact89fm.org/blog/category/sports/read/">Articles</a></li>
		<li id="menu-item-40280" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-7604 menu-item-40280"><a href="http://impact89fm.org/blog/category/sports/read/game-recaps/">Game Recaps</a></li>
		<li id="menu-item-40281" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-4779 menu-item-40281"><a href="http://impact89fm.org/blog/category/sports/professional/">Pros</a></li>
	</ul>
</li>
	<li id="menu-item-39164" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-5106 menu-item-39164"><a href="http://impact89fm.org/blog/category/news/">News</a></li>
</ul>
</li>
<li id="menu-item-39040" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-cat-293 menu-item-39040"><a href="http://impact89fm.org/blog/category/shows-2/">Listen</a>
<ul class="sub-menu">
	<li id="menu-item-39034" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39034"><a href="http://impact89fm.org/listen-live/listenlive/">Listen Live</a></li>
	<li id="menu-item-4740" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-4740"><a href="http://impact89fm.org/shows/">Music &#8211; Specialty Shows</a>
	<ul class="sub-menu">
		<li id="menu-item-38952" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38952"><a href="http://impact89fm.org/afterglow-11132016/">Afterglow</a></li>
		<li id="menu-item-38938" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38938"><a href="http://impact89fm.org/amm/">Asian Music Mondays</a></li>
		<li id="menu-item-38967" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38967"><a href="http://impact89fm.org/dispatch/">New Music Dispatch</a></li>
		<li id="menu-item-38957" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38957"><a href="http://impact89fm.org/pity-party-9-21-16/">Pity Party</a></li>
		<li id="menu-item-38918" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38918"><a href="http://impact89fm.org/basement/">The Basement</a></li>
		<li id="menu-item-38939" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38939"><a href="http://impact89fm.org/vibe/">The Vibe</a></li>
		<li id="menu-item-38928" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38928"><a href="http://impact89fm.org/power/">Thee Hourz O&#8217; Power</a></li>
		<li id="menu-item-38917" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38917"><a href="http://impact89fm.org/twang/">Torch and Twang</a></li>
	</ul>
</li>
	<li id="menu-item-4765" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-cat-5103 menu-item-4765"><a href="http://impact89fm.org/blog/category/talk/">Talk</a>
	<ul class="sub-menu">
		<li id="menu-item-38906" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38906"><a href="http://impact89fm.org/undercurrent/">The Undercurrent</a></li>
		<li id="menu-item-38973" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38973"><a href="http://impact89fm.org/citypulse/">City Pulse on the Air</a></li>
		<li id="menu-item-39157" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-7227 menu-item-39157"><a href="http://impact89fm.org/blog/category/sports/podcasts/">Sports Podcasts</a></li>
	</ul>
</li>
	<li id="menu-item-39954" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-cat-7571 menu-item-39954"><a href="http://impact89fm.org/blog/category/dj-spotlight/">DJ Spotlight</a></li>
</ul>
</li>
<li id="menu-item-26458" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-26458"><a href="http://impact89fm.org/video/">Watch</a>
<ul class="sub-menu">
	<li id="menu-item-25826" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-3807 menu-item-25826"><a href="http://impact89fm.org/blog/category/sports/video/live-performances/">Live Performances</a></li>
	<li id="menu-item-25827" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-3808 menu-item-25827"><a href="http://impact89fm.org/blog/category/sports/video/in-studio-performances/">In-Studio Performances</a></li>
	<li id="menu-item-26176" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-3901 menu-item-26176"><a href="http://impact89fm.org/blog/category/sports/video/spartan-sessions/">Spartan Sessions</a></li>
	<li id="menu-item-25825" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-3809 menu-item-25825"><a href="http://impact89fm.org/blog/category/sports/video/artist-features/">Artist Features</a></li>
	<li id="menu-item-26187" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-3908 menu-item-26187"><a href="http://impact89fm.org/blog/category/sports/video/station-news/">Station News</a></li>
</ul>
</li>
<li id="menu-item-39039" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-39039"><a>Join</a>
<ul class="sub-menu">
	<li id="menu-item-26859" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-26859"><a href="http://impact89fm.org/volunteer/">Volunteer</a></li>
	<li id="menu-item-26858" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-26858"><a href="http://impact89fm.org/jobs/">Current Job Openings</a></li>
</ul>
</li>
<li id="menu-item-4794" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-4794"><a href="http://impact89fm.org/about/">About</a>
<ul class="sub-menu">
	<li id="menu-item-31109" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-31109"><a href="http://impact89fm.org/about/">Station History</a></li>
	<li id="menu-item-4796" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4796"><a href="http://impact89fm.org/about/contact-us/">Station Hours &#038; Location</a></li>
	<li id="menu-item-25808" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-25808"><a href="http://impact89fm.org/about/staff-directory/">Staff Directory</a></li>
	<li id="menu-item-4795" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4795"><a href="http://impact89fm.org/about/submit-your-music/">Submit Music</a></li>
</ul>
</li>
</ul></div>			</nav>
			
		</div>
		
	</div>
	
	<div class="wrap">
		<div class="breadcrumbs"><span class="location">You are at:</span><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a itemprop="url" href="http://impact89fm.org/"><span itemprop="title">Home</span></a></span><span class="delim">&raquo;</span><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a itemprop="url"  href="http://impact89fm.org/blog/category/dj-spotlight/"><span itemprop="title">DJ Spotlight</span></a></span><span class="delim">&raquo;</span><span class="current">DJ Spotlight of the Week | Lorenza Centi</span></div>	</div>


<div class="main wrap cf">
	<div class="row">
		<div class="col-8 main-content">
		
			
				
<article id="post-45112" class="post-45112 post type-post status-publish format-standard has-post-thumbnail category-dj-spotlight" itemscope itemtype="http://schema.org/Article">
	
	<header class="post-header cf">

			<div class="featured">
						
							
				<a href="http://impact89fm.org/wp-content/uploads/2017/04/DJ-Spotlight_lorenza.jpg" title="DJ Spotlight of the Week | Lorenza Centi" itemprop="image">
				
								
										
						<img width="612" height="336" src="http://impact89fm.org/wp-content/uploads/2017/04/DJ-Spotlight_lorenza-612x336.jpg" class="attachment-main-slider size-main-slider wp-post-image" alt="" title="DJ Spotlight of the Week | Lorenza Centi" />					
										
												
				</a>
								
								
					</div>
	
		
		<h1 class="post-title item fn" itemprop="name">
		DJ Spotlight of the Week | Lorenza Centi		</h1>
		
		<a href="http://impact89fm.org/blog/dj-spotlight-of-the-week-lorenza-centi/#respond" class="comments"><i class="fa fa-comments-o"></i> 0</a>
		
	</header><!-- .post-header -->
	
	<div class="post-meta">
		<span class="posted-by">By 
			<span class="reviewer" itemprop="author"><a href="http://impact89fm.org/blog/author/jasmineabbasov/" title="Posts by Jasmine Abbasov" rel="author">Jasmine Abbasov</a></span>
		</span>
		 
		<span class="posted-on">on			<span class="dtreviewed">
				<time class="value-title" datetime="2017-04-24T15:40:35-04:00" title="2017-04-24" itemprop="datePublished">April 24, 2017</time>
			</span>
		</span>
		
		<span class="cats"><a href="http://impact89fm.org/blog/category/dj-spotlight/" rel="category tag">DJ Spotlight</a></span>
			
	</div>
	

	<div class="post-container cf">
	
		<div class="post-content-right">
			<div class="post-content description " itemprop="articleBody">
			
				
								
				<p>Our new DJ Spotlight of the Week is Lorenza Centi! Not only is she a DJ here at Impact, but she is also our Head Graphic Designer! When she&#8217;s not studying, you guessed it, graphic design, she&#8217;s in the studio from 12PM-2PM on Thursdays. Make sure to call in and request Beach House at 517-884-8989!</p>
<p><strong>1. What made you decide to join Impact and become a DJ?</strong></p>
<p>I started working at Impact as a graphic designer and realized I have a big mouth and a lot to say 😉</p>
<p><strong>2. What has been your best on air experience?</strong></p>
<p>Anytime I get to do dual drops/have conversations with another DJs on air is my favorite.</p>
<p><strong>3. How do you think working in radio will affect your future career and life experience?</strong></p>
<p>Definitely. It has made my realize how much I love working with musicians and in the music field and I hope to further that career path mixed with graphic design after college.</p>
<p><strong>4. What is your favorite part of the station?</strong></p>
<p>The family dynamic the station has has got to be my favorite.</p>
<p><strong>5. If you could play an artist non-stop on the air, which would it be?</strong></p>
<p>Daft Punk.</p>
<p><strong>6. What is the best concert experience you have had? Why?</strong></p>
<p>Hinds&#8217; show was the best experience I&#8217;ve had because they let fans get onstage and I was able to be one of those people to sing their final song.</p>
<!-- Simple Share Buttons Adder (6.3.4) simplesharebuttons.com --><div class="ssba ssba-wrap"><div style="text-align:center"><a data-site="" class="ssba_facebook_share" href="http://www.facebook.com/sharer.php?u=http://impact89fm.org/blog/dj-spotlight-of-the-week-lorenza-centi/"  target="_blank" ><img src="http://impact89fm.org/wp-content/plugins/simple-share-buttons-adder/buttons/simple/facebook.png" title="Facebook" class="ssba ssba-img" alt="Share on Facebook" /></a><span class="ssba_sharecount">0</span><a data-site="" class="ssba_twitter_share" href="http://twitter.com/share?url=http://impact89fm.org/blog/dj-spotlight-of-the-week-lorenza-centi/&amp;text=DJ+Spotlight+of+the+Week+%7C+Lorenza+Centi+"  target="_blank" ><img src="http://impact89fm.org/wp-content/plugins/simple-share-buttons-adder/buttons/simple/twitter.png" title="Twitter" class="ssba ssba-img" alt="Tweet about this on Twitter" /></a><a data-site="linkedin" class="ssba_linkedin_share ssba_share_link" href="http://www.linkedin.com/shareArticle?mini=true&amp;url=http://impact89fm.org/blog/dj-spotlight-of-the-week-lorenza-centi/"  target="_blank" ><img src="http://impact89fm.org/wp-content/plugins/simple-share-buttons-adder/buttons/simple/linkedin.png" title="LinkedIn" class="ssba ssba-img" alt="Share on LinkedIn" /></a><span class="ssba_sharecount">0</span><a data-site="" class="ssba_google_share" href="https://plus.google.com/share?url=http://impact89fm.org/blog/dj-spotlight-of-the-week-lorenza-centi/"  target="_blank" ><img src="http://impact89fm.org/wp-content/plugins/simple-share-buttons-adder/buttons/simple/google.png" title="Google+" class="ssba ssba-img" alt="Share on Google+" /></a><span class="ssba_sharecount">0</span><a data-site="reddit" class="ssba_reddit_share" href="http://reddit.com/submit?url=http://impact89fm.org/blog/dj-spotlight-of-the-week-lorenza-centi/&amp;title=DJ Spotlight of the Week | Lorenza Centi"  target="_blank" ><img src="http://impact89fm.org/wp-content/plugins/simple-share-buttons-adder/buttons/simple/reddit.png" title="Reddit" class="ssba ssba-img" alt="Share on Reddit" /></a><span class="ssba_sharecount">0</span><a data-site="tumblr" class="ssba_tumblr_share" href="http://www.tumblr.com/share/link?url=http://impact89fm.org/blog/dj-spotlight-of-the-week-lorenza-centi/"  target="_blank" ><img src="http://impact89fm.org/wp-content/plugins/simple-share-buttons-adder/buttons/simple/tumblr.png" title="tumblr" class="ssba ssba-img" alt="Share on Tumblr" /></a><span class="ssba_sharecount">0</span><a data-site="email" class="ssba_email_share" href="mailto:?subject=DJ%20Spotlight%20of%20the%20Week%20|%20Lorenza%20Centi&#038;body=%20http://impact89fm.org/blog/dj-spotlight-of-the-week-lorenza-centi/"><img src="http://impact89fm.org/wp-content/plugins/simple-share-buttons-adder/buttons/simple/email.png" title="Email" class="ssba ssba-img" alt="Email this to someone" /></a><a data-site="print" class="ssba_print ssba_share_link" href="#" onclick="window.print()"><img src="http://impact89fm.org/wp-content/plugins/simple-share-buttons-adder/buttons/simple/print.png" title="Print" class="ssba ssba-img" alt="Print this page" /></a></div></div>
				
								
							</div><!-- .post-content -->
		</div>
		
	</div>
	
	
			
</article>





<section class="related-posts">
	<h3 class="section-head">Related Posts</h3> 
	<ul class="highlights-box three-col related-posts">
	
		
		<li class="highlights column one-third">
			
			<article>
					
				<a href="http://impact89fm.org/blog/dj-spotlight-of-the-week-travis-root/" title="DJ Spotlight of the Week | Travis Root" class="image-link">
					<img width="214" height="140" src="http://impact89fm.org/wp-content/uploads/2017/04/DJ-Spotlight_travis_root-214x140.jpg" class="image wp-post-image" alt="" title="DJ Spotlight of the Week | Travis Root" srcset="http://impact89fm.org/wp-content/uploads/2017/04/DJ-Spotlight_travis_root-214x140.jpg 214w, http://impact89fm.org/wp-content/uploads/2017/04/DJ-Spotlight_travis_root-214x140@2x.jpg 428w" sizes="(max-width: 214px) 100vw, 214px" />
									</a>
				
				<div class="meta">
					<time datetime="2017-04-17T21:43:44-04:00">April 17, 2017 </time>
					
															
					<span class="comments"><i class="fa fa-comments-o"></i>
						0</span>	
					
				</div>
				
				<h2><a href="http://impact89fm.org/blog/dj-spotlight-of-the-week-travis-root/" title="DJ Spotlight of the Week | Travis Root">DJ Spotlight of the Week | Travis Root</a></h2>
				
			</article>
		</li>
		
		
		<li class="highlights column one-third">
			
			<article>
					
				<a href="http://impact89fm.org/blog/dj-spotlight-of-the-week-dj-hammy/" title="DJ Spotlight of the Week | DJ Hammy" class="image-link">
					<img width="214" height="140" src="http://impact89fm.org/wp-content/uploads/2017/04/DJ-Spotlight_djhammy-214x140.jpg" class="image wp-post-image" alt="" title="DJ Spotlight of the Week | DJ Hammy" srcset="http://impact89fm.org/wp-content/uploads/2017/04/DJ-Spotlight_djhammy-214x140.jpg 214w, http://impact89fm.org/wp-content/uploads/2017/04/DJ-Spotlight_djhammy-214x140@2x.jpg 428w" sizes="(max-width: 214px) 100vw, 214px" />
									</a>
				
				<div class="meta">
					<time datetime="2017-04-11T09:46:20-04:00">April 11, 2017 </time>
					
															
					<span class="comments"><i class="fa fa-comments-o"></i>
						0</span>	
					
				</div>
				
				<h2><a href="http://impact89fm.org/blog/dj-spotlight-of-the-week-dj-hammy/" title="DJ Spotlight of the Week | DJ Hammy">DJ Spotlight of the Week | DJ Hammy</a></h2>
				
			</article>
		</li>
		
		
		<li class="highlights column one-third">
			
			<article>
					
				<a href="http://impact89fm.org/blog/dj-spotlight-of-the-week-sarah-dropsey/" title="DJ Spotlight of the Week | Sarah Dropsey" class="image-link">
					<img width="214" height="140" src="http://impact89fm.org/wp-content/uploads/2017/04/DJ-Spotlight_sarah_d-214x140.jpg" class="image wp-post-image" alt="" title="DJ Spotlight of the Week | Sarah Dropsey" srcset="http://impact89fm.org/wp-content/uploads/2017/04/DJ-Spotlight_sarah_d-214x140.jpg 214w, http://impact89fm.org/wp-content/uploads/2017/04/DJ-Spotlight_sarah_d-214x140@2x.jpg 428w" sizes="(max-width: 214px) 100vw, 214px" />
									</a>
				
				<div class="meta">
					<time datetime="2017-04-04T15:17:00-04:00">April 4, 2017 </time>
					
															
					<span class="comments"><i class="fa fa-comments-o"></i>
						0</span>	
					
				</div>
				
				<h2><a href="http://impact89fm.org/blog/dj-spotlight-of-the-week-sarah-dropsey/" title="DJ Spotlight of the Week | Sarah Dropsey">DJ Spotlight of the Week | Sarah Dropsey</a></h2>
				
			</article>
		</li>
		
		</ul>
</section>


				<div class="comments">
				
	
	<div id="comments">

		
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title"><span class="section-head">Leave A Reply</span> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/blog/dj-spotlight-of-the-week-lorenza-centi/#respond" style="display:none;">Cancel Reply</a></small></h3>			<form action="http://impact89fm.org/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
				
			<p>
				<textarea name="comment" id="comment" cols="45" rows="8" aria-required="true" placeholder="Your Comment"></textarea>
			</p>
				<p>
					<input name="author" id="author" type="text" value="" size="30" aria-required="true" placeholder="Your Name" />
				</p>

				<p>
					<input name="email" id="email" type="text" value="" size="30" aria-required="true" placeholder="Your Email" />
				</p>
			

				<p>
					<input name="url" id="url" type="text" value="" size="30" placeholder="Your Website" />
				</p>
			
<p class="form-submit"><input name="submit" type="submit" id="comment-submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='45112' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="2b03289926" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="209"/></p>			</form>
			</div><!-- #respond -->
	
</div><!-- #comments -->
				</div>
	
			
		</div>
		
		
			
		
		<aside class="col-4 sidebar">
			<ul>
			
			
			<li id="bunyad-latest-posts-widget-8" class="widget latest-posts">			
							<h3 class="widgettitle">DJ Spotlight</h3>						
			<ul class="posts-list">
			
							<li>
				
					<a href="http://impact89fm.org/blog/dj-spotlight-of-the-week-lorenza-centi/"><img width="110" height="96" src="http://impact89fm.org/wp-content/uploads/2017/04/DJ-Spotlight_lorenza-110x96.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" title="DJ Spotlight of the Week | Lorenza Centi" srcset="http://impact89fm.org/wp-content/uploads/2017/04/DJ-Spotlight_lorenza-110x96.jpg 110w, http://impact89fm.org/wp-content/uploads/2017/04/DJ-Spotlight_lorenza-110x96@2x.jpg 220w" sizes="(max-width: 110px) 100vw, 110px" />					
																					
					</a>
					
					<div class="content">
					
						<time datetime="2017-04-24T15:40:35-04:00">April 24, 2017 </time>
					
						<span class="comments"><a href="http://impact89fm.org/blog/dj-spotlight-of-the-week-lorenza-centi/#respond"><i class="fa fa-comments-o"></i>
							0</a></span>
					
						<a href="http://impact89fm.org/blog/dj-spotlight-of-the-week-lorenza-centi/" title="DJ Spotlight of the Week | Lorenza Centi">
							DJ Spotlight of the Week | Lorenza Centi</a>
							
																																				
					</div>
				
				</li>
						</ul>
			
			</li>
<li id="widget_sp_image-10" class="widget widget_sp_image"><h3 class="widgettitle">Full Playlist</h3><a href="http://spinitron.com/radio/playlist.php?station=wdbm#main" id="" target="_blank" class="widget_sp_image-image-link" title="Full Playlist" rel=""><img width="214" height="140" alt="Full Playlist" class="attachment-gallery-block aligncenter" style="max-width: 100%;" srcset="http://impact89fm.org/wp-content/uploads/2013/09/spintron_graphic-01_1024-1-214x140.png, http://impact89fm.org/wp-content/uploads/2013/09/spintron_graphic-01_1024-1-214x140@2x.png 2x" /></a><div class="widget_sp_image-description" ><p>Want to see what we're spinning here at the Impact? Check out our recently played, it also features a calendar to go <em><strong>back in time</strong></em> to see past songs!</p>
</div></li>

			<li id="bunyad-latest-posts-widget-2" class="widget latest-posts">			
							<h3 class="widgettitle">Jam of the Day</h3>						
			<ul class="posts-list">
			
							<li>
				
					<a href="http://impact89fm.org/blog/location-playboi-carti/"><img width="110" height="96" src="http://impact89fm.org/wp-content/uploads/2017/04/maxresdefault-4-110x96.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" title="Location | Playboi Carti" srcset="http://impact89fm.org/wp-content/uploads/2017/04/maxresdefault-4-110x96.jpg 110w, http://impact89fm.org/wp-content/uploads/2017/04/maxresdefault-4-110x96@2x.jpg 220w" sizes="(max-width: 110px) 100vw, 110px" />					
																					
					</a>
					
					<div class="content">
					
						<time datetime="2017-04-21T12:00:23-04:00">April 21, 2017 </time>
					
						<span class="comments"><a href="http://impact89fm.org/blog/location-playboi-carti/#respond"><i class="fa fa-comments-o"></i>
							0</a></span>
					
						<a href="http://impact89fm.org/blog/location-playboi-carti/" title="Location | Playboi Carti">
							Location | Playboi Carti</a>
							
																																				
					</div>
				
				</li>
							<li>
				
					<a href="http://impact89fm.org/blog/rewind-feat-griz-flint-eastwood/"><img width="110" height="96" src="http://impact89fm.org/wp-content/uploads/2017/04/13925490_1174479975949695_7837944706998617371_o-110x96.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" title="Rewind (Feat. GRIZ) | Flint Eastwood" srcset="http://impact89fm.org/wp-content/uploads/2017/04/13925490_1174479975949695_7837944706998617371_o-110x96.jpg 110w, http://impact89fm.org/wp-content/uploads/2017/04/13925490_1174479975949695_7837944706998617371_o-110x96@2x.jpg 220w" sizes="(max-width: 110px) 100vw, 110px" />					
																					
					</a>
					
					<div class="content">
					
						<time datetime="2017-04-19T13:05:28-04:00">April 19, 2017 </time>
					
						<span class="comments"><a href="http://impact89fm.org/blog/rewind-feat-griz-flint-eastwood/#respond"><i class="fa fa-comments-o"></i>
							0</a></span>
					
						<a href="http://impact89fm.org/blog/rewind-feat-griz-flint-eastwood/" title="Rewind (Feat. GRIZ) | Flint Eastwood">
							Rewind (Feat. GRIZ) | Flint Eastwood</a>
							
																																				
					</div>
				
				</li>
						</ul>
			
			</li>

			<li id="bunyad-latest-posts-widget-7" class="widget latest-posts">			
							<h3 class="widgettitle">Sports</h3>						
			<ul class="posts-list">
			
							<li>
				
					<a href="http://impact89fm.org/blog/durkins-big-day-cant-top-buckeyes-in-high-scoring-loss/"><img width="110" height="96" src="http://impact89fm.org/wp-content/uploads/2017/04/DSC_0314-1-110x96.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" title="Durkin&#8217;s big day can&#8217;t top Buckeyes in high-scoring loss" srcset="http://impact89fm.org/wp-content/uploads/2017/04/DSC_0314-1-110x96.jpg 110w, http://impact89fm.org/wp-content/uploads/2017/04/DSC_0314-1-110x96@2x.jpg 220w" sizes="(max-width: 110px) 100vw, 110px" />					
																					
					</a>
					
					<div class="content">
					
						<time datetime="2017-04-17T09:38:19-04:00">April 17, 2017 </time>
					
						<span class="comments"><a href="http://impact89fm.org/blog/durkins-big-day-cant-top-buckeyes-in-high-scoring-loss/#respond"><i class="fa fa-comments-o"></i>
							0</a></span>
					
						<a href="http://impact89fm.org/blog/durkins-big-day-cant-top-buckeyes-in-high-scoring-loss/" title="Durkin&#8217;s big day can&#8217;t top Buckeyes in high-scoring loss">
							Durkin&#8217;s big day can&#8217;t top Buckeyes in high-scoring loss</a>
							
																																				
					</div>
				
				</li>
							<li>
				
					<a href="http://impact89fm.org/blog/detorit-lions-four-round-mock-draft/"><img width="110" height="96" src="http://impact89fm.org/wp-content/uploads/2015/09/lions_1_1024-110x96.png" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" title="Detroit Lions Four Round Mock Draft" srcset="http://impact89fm.org/wp-content/uploads/2015/09/lions_1_1024-110x96.png 110w, http://impact89fm.org/wp-content/uploads/2015/09/lions_1_1024-110x96@2x.png 220w" sizes="(max-width: 110px) 100vw, 110px" />					
																					
					</a>
					
					<div class="content">
					
						<time datetime="2017-04-17T08:00:34-04:00">April 17, 2017 </time>
					
						<span class="comments"><a href="http://impact89fm.org/blog/detorit-lions-four-round-mock-draft/#respond"><i class="fa fa-comments-o"></i>
							0</a></span>
					
						<a href="http://impact89fm.org/blog/detorit-lions-four-round-mock-draft/" title="Detroit Lions Four Round Mock Draft">
							Detroit Lions Four Round Mock Draft</a>
							
																																				
					</div>
				
				</li>
							<li>
				
					<a href="http://impact89fm.org/blog/spartans-edge-buckeyes-in-6-5-thriller/"><img width="110" height="96" src="http://impact89fm.org/wp-content/uploads/2017/04/DSC_0619-110x96.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" title="Spartans edge Buckeyes in 6-5 thriller" srcset="http://impact89fm.org/wp-content/uploads/2017/04/DSC_0619-110x96.jpg 110w, http://impact89fm.org/wp-content/uploads/2017/04/DSC_0619-110x96@2x.jpg 220w" sizes="(max-width: 110px) 100vw, 110px" />					
																					
					</a>
					
					<div class="content">
					
						<time datetime="2017-04-15T18:03:45-04:00">April 15, 2017 </time>
					
						<span class="comments"><a href="http://impact89fm.org/blog/spartans-edge-buckeyes-in-6-5-thriller/#respond"><i class="fa fa-comments-o"></i>
							0</a></span>
					
						<a href="http://impact89fm.org/blog/spartans-edge-buckeyes-in-6-5-thriller/" title="Spartans edge Buckeyes in 6-5 thriller">
							Spartans edge Buckeyes in 6-5 thriller</a>
							
																																				
					</div>
				
				</li>
						</ul>
			
			</li>

			<li id="bunyad-latest-posts-widget-4" class="widget latest-posts">			
							<h3 class="widgettitle">Latest Videos</h3>						
			<ul class="posts-list">
			
							<li>
				
					<a href="http://impact89fm.org/blog/msu-hockey-b1g-tournament-wrap-up/"><img width="110" height="96" src="http://impact89fm.org/wp-content/uploads/2017/03/2017-03-17-1-110x96.png" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" title="MSU Hockey B1G Tournament Wrap-Up" srcset="http://impact89fm.org/wp-content/uploads/2017/03/2017-03-17-1-110x96.png 110w, http://impact89fm.org/wp-content/uploads/2017/03/2017-03-17-1-110x96@2x.png 220w" sizes="(max-width: 110px) 100vw, 110px" />					
																					
					</a>
					
					<div class="content">
					
						<time datetime="2017-03-17T17:51:13-04:00">March 17, 2017 </time>
					
						<span class="comments"><a href="http://impact89fm.org/blog/msu-hockey-b1g-tournament-wrap-up/#respond"><i class="fa fa-comments-o"></i>
							0</a></span>
					
						<a href="http://impact89fm.org/blog/msu-hockey-b1g-tournament-wrap-up/" title="MSU Hockey B1G Tournament Wrap-Up">
							MSU Hockey B1G Tournament Wrap-Up</a>
							
																																				
					</div>
				
				</li>
							<li>
				
					<a href="http://impact89fm.org/blog/what-msu-baseball-learned-from-playing-elite-programs/"><img width="110" height="96" src="http://impact89fm.org/wp-content/uploads/2017/03/2017-03-16-1-110x96.png" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" title="What MSU baseball learned from playing elite programs" srcset="http://impact89fm.org/wp-content/uploads/2017/03/2017-03-16-1-110x96.png 110w, http://impact89fm.org/wp-content/uploads/2017/03/2017-03-16-1-110x96@2x.png 220w" sizes="(max-width: 110px) 100vw, 110px" />					
																					
					</a>
					
					<div class="content">
					
						<time datetime="2017-03-16T20:24:37-04:00">March 16, 2017 </time>
					
						<span class="comments"><a href="http://impact89fm.org/blog/what-msu-baseball-learned-from-playing-elite-programs/#respond"><i class="fa fa-comments-o"></i>
							0</a></span>
					
						<a href="http://impact89fm.org/blog/what-msu-baseball-learned-from-playing-elite-programs/" title="What MSU baseball learned from playing elite programs">
							What MSU baseball learned from playing elite programs</a>
							
																																				
					</div>
				
				</li>
							<li>
				
					<a href="http://impact89fm.org/blog/spartans-hold-on-for-senior-day-victory-over-no-16-wisconsin/"><img width="110" height="96" src="http://impact89fm.org/wp-content/uploads/2017/02/File_000-6-110x96.jpeg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" title="Spartans Hold On for Senior Day Victory over No. 16 Wisconsin" srcset="http://impact89fm.org/wp-content/uploads/2017/02/File_000-6-110x96.jpeg 110w, http://impact89fm.org/wp-content/uploads/2017/02/File_000-6-110x96@2x.jpeg 220w" sizes="(max-width: 110px) 100vw, 110px" />					
																					
					</a>
					
					<div class="content">
					
						<time datetime="2017-02-26T18:26:20-04:00">February 26, 2017 </time>
					
						<span class="comments"><a href="http://impact89fm.org/blog/spartans-hold-on-for-senior-day-victory-over-no-16-wisconsin/#respond"><i class="fa fa-comments-o"></i>
							0</a></span>
					
						<a href="http://impact89fm.org/blog/spartans-hold-on-for-senior-day-victory-over-no-16-wisconsin/" title="Spartans Hold On for Senior Day Victory over No. 16 Wisconsin">
							Spartans Hold On for Senior Day Victory over No. 16 Wisconsin</a>
							
																																				
					</div>
				
				</li>
							<li>
				
					<a href="http://impact89fm.org/blog/everything-you-need-to-know-for-the-2017-spartan-baseball-season/"><img width="110" height="96" src="http://impact89fm.org/wp-content/uploads/2017/02/2017-02-24-4-110x96.png" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" title="Everything you need to know for the 2017 Spartan Baseball season" srcset="http://impact89fm.org/wp-content/uploads/2017/02/2017-02-24-4-110x96.png 110w, http://impact89fm.org/wp-content/uploads/2017/02/2017-02-24-4-110x96@2x.png 220w" sizes="(max-width: 110px) 100vw, 110px" />					
																					
					</a>
					
					<div class="content">
					
						<time datetime="2017-02-24T12:18:01-04:00">February 24, 2017 </time>
					
						<span class="comments"><a href="http://impact89fm.org/blog/everything-you-need-to-know-for-the-2017-spartan-baseball-season/#respond"><i class="fa fa-comments-o"></i>
							0</a></span>
					
						<a href="http://impact89fm.org/blog/everything-you-need-to-know-for-the-2017-spartan-baseball-season/" title="Everything you need to know for the 2017 Spartan Baseball season">
							Everything you need to know for the 2017 Spartan Baseball season</a>
							
																																				
					</div>
				
				</li>
						</ul>
			
			</li>
	
			</ul>
		</aside>
		
			
	</div> <!-- .row -->
</div> <!-- .main -->


		
	<footer class="main-footer">
	
		
	
			<div class="lower-foot">
			<div class="wrap">
		
						
			<div class="widgets">
							<div class="textwidget">© 2017 Michigan State University Board of Trustees</div>
		<div class="menu-lower-footer-links-container"><ul id="menu-lower-footer-links" class="menu"><li id="menu-item-25798" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-25798"><a href="http://impact89fm.org/about/contact-us/">Contact Us</a></li>
<li id="menu-item-28263" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28263"><a href="http://www.last.fm/user/Impact89FM">Find a Song</a></li>
<li id="menu-item-25797" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-25797"><a href="http://impact89fm.org/about/submit-your-music/">Submit Music</a></li>
<li id="menu-item-30877" class="menu-item menu-item-type-post_type menu-item-object-wpgform menu-item-30877"><a href="http://impact89fm.org/wpgforms/support-request/">Report a Problem</a></li>
<li id="menu-item-25796" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-25796"><a href="http://impact89fm.org/about/">About Impact</a></li>
<li id="menu-item-25945" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-25945"><a href="http://impact89fm.org/wp-admin/">Admin</a></li>
</ul></div>			</div>
			
					
			</div>
		</div>		
		
	</footer>
	
</div> <!-- .main-wrap -->

<script type='text/javascript' src='http://impact89fm.org/wp-content/plugins/akismet/_inc/form.js?ver=3.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"http:\/\/impact89fm.org\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='http://impact89fm.org/wp-includes/js/thickbox/thickbox.js?ver=3.1-20121105'></script>
<script type='text/javascript' src='http://impact89fm.org/wp-includes/js/comment-reply.min.js?ver=4.7.4'></script>
<script type='text/javascript' src='http://impact89fm.org/wp-content/plugins/contact-form-7/includes/js/jquery.form.min.js?ver=3.51.0-2014.06.20'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpcf7 = {"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}}};
/* ]]> */
</script>
<script type='text/javascript' src='http://impact89fm.org/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=4.6.1'></script>
<script type='text/javascript' src='http://impact89fm.org/wp-content/plugins/simple-share-buttons-adder/js/ssba.min.js?ver=4.7.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var Bunyad = {"ajaxurl":"http:\/\/impact89fm.org\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://impact89fm.org/wp-content/themes/smart-mag/js/bunyad-theme.js?ver=2.4.1'></script>
<script type='text/javascript' src='http://impact89fm.org/wp-content/themes/smart-mag/js/jquery.flexslider-min.js?ver=2.4.1'></script>
<script type='text/javascript' src='http://impact89fm.org/wp-includes/js/wp-embed.min.js?ver=4.7.4'></script>

</body>
</html>